Introduction

This course will give you the skills to perform simple data analysis in Excel. You will learn how to use formulas, conditional formatting, filtering and sorting and many more data analysis features to help you in your work. This course will increase your competence in day-to-day data analysis making you more efficient and productive.

Topics Include

- Use workbooks as templates for other workbooks.
- Manipulate worksheet data.
- Use intermediate data management tools such as filters and advanced filters.
- Summarize data that meets specific conditions.
- Link to data in other worksheets and workbooks.
- Locate and use some of the more complex Excel functions.
- Create and modify charts.

Prerequisite

Comfortable with Windows 7, or OSX

Platform

Windows, OSX

Software

Microsoft Excel 2013, Microsoft Excel 2010 (Windows)

Microsoft Excel 2011 (MAC)

Instructor

Anna Neagu – Application Support Consultant
# Excel Training - Level 2

## Table of Contents

1. Worksheet Organization ............................................................................................................. 5
   1.1. Using Workbook Templates ................................................................................................. 5
2. Data Analysis .............................................................................................................................. 18
   2.1. AutoFilter and Advanced Filter ......................................................................................... 18
      2.1.1. AutoFilter .................................................................................................................. 18
      2.1.2. Advanced Filter ......................................................................................................... 21
   2.2. Creating and Using Outlines ............................................................................................. 24
      2.2.1. Grouping Rows or Columns ....................................................................................... 24
      2.2.2. Creating subtotals ..................................................................................................... 26
   2.3. Conditional Formatting ..................................................................................................... 30
   2.4. Sparklines .......................................................................................................................... 34
      2.4.1. Types of sparklines ..................................................................................................... 34
      2.4.2. Modifying sparklines ................................................................................................. 36
   2.5. Collating Data from Several Worksheets ......................................................................... 39
3. Advanced Functions ...................................................................................................................... 43
   3.1. AutoSum .............................................................................................................................. 44
   3.2. IF Function ........................................................................................................................ 45
   3.3. vlookup Function .............................................................................................................. 46
   3.4. What-If Analysis ................................................................................................................. 48
   3.5. Name Ranges ...................................................................................................................... 50
   3.6. Array formulas ................................................................................................................... 52
4. Using Tables ............................................................................................................................... 55
5. Chart Tools .................................................................................................................................. 59
   5.1. Formatting a chart .............................................................................................................. 61
5.2. Creating a Combo Chart........................................................................................................... 62

6. Applying Formatting....................................................................................................................... 64
   6.1. Working with Styles.................................................................................................................. 64
   6.2. Insert headers and footers...................................................................................................... 66
   6.3. Paste Special............................................................................................................................ 67
1. Worksheet Organization

The Excel 2013 "Big Grid" increases the maximum number of rows per worksheet from 65,536 to over 1 million, and the number of columns from 256 to 16,384. When you open a new workbook there is 1 worksheet by default.

1.1. Using Workbook Templates

A template is a predesigned spreadsheet you can use to create a new workbook quickly. Templates often include custom formatting and predefined formulas, so they can save you a lot of time and effort when starting a new project.

To create a new workbook from a template

1. Click the File tab to access Backstage view.

2. Select New. Several templates will appear below the Blank workbook option.

3. Select a template to review it.
4. A **preview** of the template will appear, along with **additional information** on how the template can be used.

5. Click **Create** to use the selected template.

### Sales invoice tracker

**Provided by: Microsoft Corporation**

This template is more than a one dimensional invoice. It actually is designed to maintain a history of customers, invoices, and invoice details so you can store multiple invoices without creating multiple files. You can also use the Invoice Tracker to analyze your previously invoiced data.

**Download size:** 59 KB

6. A new workbook will appear with the **selected template**.

andelier: You can also browse templates by **category** or use the **search bar** to find something more specific.
1.2. View Options

If your workbook contains a lot of content, it can sometimes be difficult to compare different sections. Excel includes additional options to make your workbooks easier to view and compare. For example, you can choose to **open a new window** for your workbook or **split a worksheet** into separate panes.

**To open a new window for the current workbook**

Excel allows you to open **multiple windows** for a single workbook at the same time. In our example, we'll use this feature to compare two different **worksheets** from the same workbook.

1. Click the **View** tab on the **Ribbon**, then select the **New Window** command.

2. A **new window** for the workbook will appear.

3. You can now compare different worksheets from the same workbook across windows.

   **TIP:** If you have several windows open at the same time, you can use the **Arrange All** command to rearrange them quickly.
To split a worksheet

Sometimes you may want to compare different sections of the same workbook without creating a new window. The **Split** command allows you to **divide** the worksheet into multiple panes that scroll separately.

1. Select the **cell** where you wish to split the worksheet.
2. Click the **View** tab on the **Ribbon**, then select the **Split** command.
3. The workbook will be **split** into different **panes**. You can scroll through each pane separately using the **scroll bars**, allowing you to compare different sections of the workbook.

**TIP**: After creating a split, you can click and drag the vertical and horizontal dividers to change the size of each section.
To remove the split, click the **Split** command again.

### 1.3. Finalizing and Protecting Workbooks

Before sharing a workbook, you'll want to make sure it doesn't include any spelling errors or information you wish to keep private. Fortunately, Excel includes several tools to help **finalize** and **protect** your workbook, such as **Spell Check** and the **Document Inspector**.

#### 1.3.1. Spell Check

1. From the **Review** tab, click the **Spelling** command.

2. The **Spelling** dialog box will appear. For each spelling error in your worksheet, Spell Check will try to offer **suggestions** for the correct spelling. Choose a suggestion, then click **Change** to correct the error.

   🔄 **TIP:** If there are no appropriate suggestions, you can also enter the correct spelling manually.
3. A dialog box will appear after reviewing all spelling errors. Click **OK** to close Spell Check.

![Spell Check Complete](image)

**Ignoring spelling "errors"**

Spell Check *isn't always correct*. It will sometimes mark certain words as incorrect, even if they're spelled correctly. This often happens with names, which may not be in the dictionary. You can choose **not** to change a spelling "error" using one of three options:

- **Ignore Once**: This will skip the word without changing it.
- **Ignore All**: This will skip the word without changing it and also skip all other instances of the word in your worksheet.
- **Add**: This adds the word to the dictionary so it will never appear as an error again. Make sure the word is spelled correctly before choosing this option.

1.3.2. **Document Inspector**  

Whenever you create or edit a workbook, certain **personal information** may be added to the file automatically. You can use the Document Inspector to remove this kind of information before sharing a workbook with others.

Because some changes may be permanent, it's a good idea to save an additional copy of your workbook before using the Document Inspector to remove information.

1. Click the **File** tab to access **Backstage view**.

2. From the **Info** pane, click **Check for Issues**, then select **Inspect Document** from the drop-down menu.
3. The **Document Inspector** will appear. Check or uncheck boxes, depending on the content you wish to review, then click **Inspect**.
4. The **inspection results** will appear. In our example, we can see that our workbook contains some personal information, so we'll click **Remove All** to remove that information from the workbook.

5. When you're done, click **Close**.

### 1.3.3. Protecting Your Workbook

By default, anyone with access to your workbook will be able to open, copy, and edit its content unless you **protect** it. There are many different ways to protect a workbook, depending on your needs.

*To protect your workbook*

1. Click the **File** tab to access **Backstage view**.
2. From the **Info** pane, click the **Protect Workbook** command.
3. In the drop-down menu, choose the option that best suits your needs. In our example, we'll select **Mark as Final**. *Marking your workbook as final is a good way to discourage others from editing the workbook, while the other options give you even more control if needed.*
4. A dialog box will appear, prompting you to save. Click **OK**.

5. Another dialog box will appear. Click **OK**.
6. The workbook will be marked as final.

**TIP:** Marking a workbook as final will not prevent someone from editing it. If you want to prevent people from editing it, you can use the **Restrict Access** option instead.

**Challenge!**

1. Open an existing Excel workbook.
2. Run the **Spell Check** to correct any spelling errors in the workbook.
3. Use the **Document Inspector** to check the workbook.
4. **Protect** the workbook by marking it as final.

### 1.3.4. Password Protect Workbook

When you share a workbook with other users, you may want to protect data in specific worksheet or workbook elements to help prevent it from being changed. You can also specify a password that users must enter to modify specific, protected worksheet and workbook elements. In addition, you can prevent users from changing the structure of a worksheet.

When you protect a worksheet or workbook by locking its elements, adding a password to edit the unlocked elements is optional. In this context, the password is only intended to allow access to certain users while helping to prevent changes by other users. This level of password protection does not
guarantee that all sensitive data in your workbook is secure. For optimal security, you should secure a workbook itself with a password to help safeguard it from unauthorized access.

When you protect worksheet or workbook elements by using a password, it is very important that you

**TIP**: It is critical that you remember your password. If you forget your password, Microsoft cannot retrieve it. Store the passwords that you write down in a secure place away from the information that they help protect.

*To Password Protect Workbook*

If you protect the workbook structure, users cannot insert, delete, rename, move, copy, hide or unhide worksheets anymore.

1. Open a workbook.
2. On the **Review** tab, click **Protect Workbook**.
3. Check **Structure**, enter a password and click **OK**.
4. Re-enter the password and click on **OK**.
TIP: If you protect the workbook windows, users cannot move, change the size and close windows anymore.

To unprotect the workbook, click Protect Workbook and enter the password.

**To Protect Worksheet Elements**

When you share a file with other users, you may want to **protect a worksheet** to help prevent it from being changed.

1. On the **Review** tab, click **Protect Sheet**.
2. Click **Protect Sheet**.
3. Enter a password.
4. Check the actions you allow the users of your worksheet to perform.
5. Click **OK**.
6. Confirm the password and click **OK**.

![Confirm Password dialog box](image)

### 1.3.5. Lock Cells

You can **lock cells** if you want to protect cells from being edited.

Before you start: by default, all cells are **locked**.

 **TIP:** Locking cells has no effect until you protect the worksheet. So when you protect a worksheet, all your cells (=worksheet) will be locked. As a result, if you want to lock a cell, you have to unlock all cells first, lock a cell, and then protect the sheet.

1. Select all cells.
2. Right click, and then click **Format Cells**.
3. On the **Protection** tab, check the **Locked** check box and click **OK**.

![Format Cells dialog box](image)

 **TIP:** If you also check the Hidden check box, users cannot see the formula in the formula bar when they select a cell.
2. Data Analysis

If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters can be used to narrow down the data in your worksheet, allowing you to view only the information you need.

2.1. AutoFilter and Advanced Filter

Filtering rows allows you to include or exclude rows based upon a value. When a column is filtered a small filter icon (▼) appears in the column header.

2.1.1. AutoFilter

The AutoFilter feature puts drop-down arrows (with menus) in the titles of each column. The menus are used to select criteria in the column so that only records that meet the specified criteria are displayed.

1. In order for filtering to work correctly, your worksheet should include a header row, which is used to identify the name of each column.

2. Select the Data tab, then click the Filter command. (Mac Users – Same Tab)

3. A drop-down arrow ▼ will appear in the header cell for each column.
4. Click the **drop-down arrow** for the column you wish to filter.

<table>
<thead>
<tr>
<th>Opportunity Name</th>
<th>Sales Agent</th>
<th>Sales Region</th>
<th>Sales Category</th>
<th>Forecast Amount</th>
<th>Sales Phase</th>
<th>Probability of Sale</th>
<th>Year</th>
<th>Forecast Close</th>
</tr>
</thead>
<tbody>
<tr>
<td>A. Datum Corporation</td>
<td>Sales Agent 1</td>
<td>US - Northeast</td>
<td>Consulting</td>
<td>$150,000</td>
<td>Formal Approval</td>
<td>90% 2013 January</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fabrikam, Inc.</td>
<td>Sales Agent 4</td>
<td>EMEA - Other</td>
<td>Consulting</td>
<td>$166,000</td>
<td>Opportunity</td>
<td>10% 2013 January</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Adventure Works</td>
<td>Sales Agent 2</td>
<td>US - Southeast</td>
<td>Products</td>
<td>$145,200</td>
<td>Opportunity</td>
<td>10% 2013 February</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Northwind Traders</td>
<td>Sales Agent 3</td>
<td>US - South Central</td>
<td>Prof. Services</td>
<td>$162,000</td>
<td>Verbal Approval</td>
<td>90% 2013 February</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alpine Ski House</td>
<td>Sales Agent 3</td>
<td>US - North Central</td>
<td>Training</td>
<td>$162,500</td>
<td>Identified Need</td>
<td>20% 2013 March</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fourth Coffee</td>
<td>Sales Agent 3</td>
<td>APSA - Asia</td>
<td>Training</td>
<td>$180,000</td>
<td>Budget Validated</td>
<td>30% 2013 March</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Proseware, Inc.</td>
<td>Sales Agent 4</td>
<td>Canada - East</td>
<td>Mixture</td>
<td>$157,000</td>
<td>Formal Approval</td>
<td>100% 2013 March</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Baldwin Museum of Science</td>
<td>Sales Agent 4</td>
<td>US - South Central</td>
<td>Mixture</td>
<td>$147,500</td>
<td>Sponsorship</td>
<td>30% 2013 April</td>
<td></td>
<td></td>
</tr>
<tr>
<td>School of Fine Art</td>
<td>Sales Agent 3</td>
<td>EMEA - France</td>
<td>Services</td>
<td>$173,000</td>
<td>Budget Validated</td>
<td>40% 2013 April</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. The **Filter menu** will appear.

6. **Uncheck** the box next to **Select All** to quickly deselect all data.

7. **Check** the boxes next to the data you wish to filter, then click **OK**.

8. The data will be **filtered**, temporarily hiding any content that doesn't match the criteria.
To Create Criteria

1. Point to Text Filters and then click one of the comparison operators or click Custom Filter.

2. For example, to filter by text that begins with a specific character, select Begins With, or to filter by text that has specific characters anywhere in the text, select Contains.

3. In the Custom AutoFilter dialog box, in the box on the right, enter text or select the text value from the list. Optionally, filter by one more criteria.

To add one or more criteria

1. To filter the table column or selection so that both criteria must be true, select And.

2. To filter the table column or selection so that either or both criteria can be true, select Or.
3. In the second entry, select a comparison operator, and then in the box on the right, enter text or select a text value from the list.

To remove criteria

1. Click anywhere with the filtered list.
2. On the Data Tab in the Sort & Filter group click on the Clear button.
3. The full list will be displayed again but the filter dropdown arrows are still available.

To remove all filters from your worksheet, click the Filter command on the Data tab.

2.1.2. Advanced Filter

If you need to filter for something specific, basic filtering may not give you enough options. Fortunately, Excel includes many advanced filtering tools, including search, text, date, and number filtering, which can narrow your results to help find exactly what you need.

To filter with search

Excel allows you to search for data that contains an exact phrase, number, date, and more.

1. Select the Data tab, then click the Filter command. A drop-down arrow will appear in the header cell for each column. Note: If you've already added filters to your worksheet, you can skip this step.
2. Click the drop-down arrow for the column you wish to filter.
3. The Filter menu will appear. Enter a search term into the search box. Search results will appear automatically below the Text Filters field as you type.
4. When you're done, click OK.
5. The worksheet will be filtered according to your search term.
To use advanced text filters

Advanced text filters can be used to display more specific information, such as cells that contain a certain number of characters, or data that excludes a specific word or number.

☑ And Criteria

To find data that meets one condition in two or more columns, enter all the criteria in the same row of the criteria range.

1. Enter the criteria shown below on the worksheet.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Last Name</td>
<td>Sales</td>
<td>Country</td>
<td>Quarter</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>$145,258.00</td>
<td>Canada</td>
<td>Q1</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>$475,822.00</td>
<td>Canada</td>
<td>Q4</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>$169,854.00</td>
<td>US</td>
<td>Q4</td>
</tr>
<tr>
<td>5</td>
<td>Last Name</td>
<td>Sales</td>
<td>Country</td>
<td>Quarter</td>
</tr>
<tr>
<td>6</td>
<td>Smith</td>
<td>$145,258.00</td>
<td>Canada</td>
<td>Q1</td>
</tr>
<tr>
<td>7</td>
<td>Johnson</td>
<td>$475,822.00</td>
<td>Canada</td>
<td>Q4</td>
</tr>
<tr>
<td>8</td>
<td>Doe</td>
<td>$169,854.00</td>
<td>US</td>
<td>Q4</td>
</tr>
<tr>
<td>9</td>
<td>Black</td>
<td>$152,888.00</td>
<td>Canada</td>
<td>Q3</td>
</tr>
<tr>
<td>10</td>
<td>Williams</td>
<td>$6,000.00</td>
<td>US</td>
<td>Q1</td>
</tr>
<tr>
<td>11</td>
<td>Brown</td>
<td>$5,200.00</td>
<td>US</td>
<td>Q2</td>
</tr>
</tbody>
</table>

2. Click any single cell inside the data set.


4. Click in the Criteria range box and select the range C1:D2.

5. Click OK.
**Or Criteria**

To find data that meets either a condition in one column or a condition in another column, enter the criteria in different rows of the criteria range.

1. Enter the criteria shown below on the worksheet.
2. On the Data tab, click Advanced, and adjust the Criteria range to range C1:D3.
3. Click OK.
☑ Formula as Criteria

1. Enter the criteria (+formula) shown below on the worksheet.

2. On the Data tab, click Advanced, and adjust the Criteria range to range B1:D3.

3. Click OK.

![Excel Spreadsheet showing Data Filter]

To turn off the Advanced Filter click on Clear from the Data tab in the Sort & Filter Group.

2.2. Creating and Using Outlines

Worksheets with a lot of content can sometimes feel overwhelming and even become difficult to read. Fortunately, Excel can organize data in groups, allowing you to easily show and hide different sections of your worksheet. You can also summarize different groups using the Subtotal command and create an outline for your worksheet.

2.2.1. Grouping Rows or Columns

1. Select the rows or columns you wish to group. In this example, we'll select columns A, B, and C.
2. Select the **Data** tab on the **Ribbon**, then click the **Group** command.

3. The selected rows or columns will be **grouped**.
To **ungroup** data, select the grouped rows or columns, then click the **Ungroup** command.

![Excel Interface](image.png)

**To hide and show groups**

1. To hide a group, click the **Hide Detail** button.

   ![Hide Group](image2.png)

2. The group will be hidden. To show a hidden group, click the **Show Detail** button.

   ![Show Group](image3.png)

**2.2.2. Creating subtotals**

The **Subtotal** command allows you to automatically **create groups** and use common functions like **SUM**, **COUNT**, and **AVERAGE** to help **summarize** your data. For example, the Subtotal command could help to calculate the cost of office supplies by type from a large inventory order. The **Subtotal** command will create a hierarchy of groups, known as an **outline**, to help organize your worksheet.

**To create a subtotal**

In our example, we will use the Subtotal command with a T-shirt order form to determine how many T-shirts were ordered in each size (Small, Medium, Large, and X-Large). This will create an **outline** for our worksheet with a **group** for each T-shirt size and then **count** the total number of shirts in each group.

1. First, **sort** your worksheet by the data you wish to subtotal. In this example, we will create a subtotal for each T-shirt size, so our worksheet has been sorted by T-shirt size from smallest to largest.
2. Select the **Data** tab, then click the **Subtotal** command.

3. The **Subtotal** dialog box will appear. Click the drop-down arrow for the **At each change in:** field to select the **column** you wish to subtotal. In our example, we'll select **T-Shirt Size**.

4. Click the drop-down arrow for the **Use function:** field to select the **function** you wish to use. In our example, we’ll select **COUNT** to count the number of shirts ordered in each size.

5. In the **Add subtotal to:** field, select the **column** where you want the **calculated subtotal** to appear. In our example, we’ll select **T-Shirt Size**.

6. When you're satisfied with your selections, click **OK**.

7. The worksheet will be **outlined** into groups, and the **subtotal** will be listed below each group. In our example, the data is now grouped by T-shirt size, and the number of shirts ordered in that size appears below each group.
To view groups by level

When you create subtotals, your worksheet it is divided into different levels. You can switch between these levels to quickly control how much information is displayed in the worksheet by clicking the Level buttons to the left of the worksheet. In our example, we'll switch between all three levels in our outline. While this example contains only three levels, Excel can accommodate up to eight.

1. Click the lowest level to display the least detail (level 1).
2. Click the next level to expand the detail. In our example, we'll select level 2, which contains each subtotal row but hides all other data from the worksheet.
3. Click the **highest level** to view and expand all of your worksheet data (level 2).

**TIP:** You can also use the Show and Hide Detail buttons to show and hide the groups within the outline.

*To remove subtotals*

Sometimes you may not want to keep subtotals in your worksheet, especially if you want to reorganize data in different ways. If you no longer wish to use subtotalling, you'll need **remove it** from your worksheet.

1. Select the **Data** tab, then click the **subtotal** command.
2. The **subtotal** dialog box will appear. Click **Remove All**.

3. All worksheet data will be **ungrouped**, and the subtotals will be **removed**.

**TIP:** To remove all groups without deleting the subtotals, click the **Ungroup** command drop-down arrow, then choose **Clear Outline.**

*Challenge!*

1. Open an existing Excel workbook.
2. Try **grouping** a range of rows or columns together.
3. Use the Show and Hide Detail buttons to hide and unhide the group.
4. Try **ungrouping** the group.
5. **Outline** your worksheet using the **Subtotal** command.
6. **Remove subtotalling** from your worksheet.
2.3. Conditional Formatting

Let's imagine you have a worksheet with thousands of rows of data. It would be extremely difficult to see patterns and trends just from examining the raw information. Similar to charts and sparklines, conditional formatting provides another way to visualize data and make worksheets easier to understand.

Understanding conditional formatting

Conditional formatting allows you to automatically apply formatting—such as colors, icons, and data bars—to one or more cells based on the cell value. To do this, you'll need to create a conditional formatting rule. For example, a conditional formatting rule might be: "If the value is less than $2000, color the cell red." By applying this rule, you'd be able to quickly see which cells contain values under $2000.

Note: When you create a conditional format, you can only reference other cells on the same worksheet; you cannot reference cells on other worksheets in the same workbook, or use external references to another workbook.

To create a conditional formatting rule

In our example, we have a worksheet containing sales data, and we'd like to see which salespeople are meeting their monthly sales goals. The sales goal is $4000 per month, so we'll create a conditional formatting rule for any cells containing a value higher than 4000.

1. Select the desired cells for the conditional formatting rule.

2. From the Home tab, click the Conditional Formatting command. A drop-down menu will appear.
3. Hover the mouse over the desired conditional formatting type, then select the desired rule from the menu that appears. In our example, we want to highlight cells that are greater than $4000.

![Excel screenshot showing conditional formatting]

4. A dialog box will appear. Enter the desired value(s) into the blank field. In our example, we'll enter 4000 as our value.

5. Select a formatting style from the drop-down menu. In our example, we'll choose Green Fill with Dark Green Text, then click OK.

6. The conditional formatting will be applied to the selected cells. In our example, it's easy to see which salespeople reached the $4000 sales goal for each month.

> TIP: You can apply multiple conditional formatting rules to a cell range or worksheet, allowing you to visualize different trends and patterns in your data.

**To remove conditional formatting**

1. Click the Conditional Formatting command. A drop-down menu will appear.

2. Hover the mouse over Clear Rules, and choose which rules you wish to clear. In our example, we'll select Clear Rules from Entire Sheet to remove all conditional formatting from the worksheet.
3. The conditional formatting will be removed.

**TIP:** Click **Manage Rules** to edit or delete individual rules. This is especially useful if you have applied multiple rules to a worksheet.

---

**Conditional formatting presets**

Excel has a number of predefined styles, or **presets**, you can use to quickly apply conditional formatting to your data. They are grouped into three categories:
• **Data Bars** are horizontal bars added to each cell, much like a **bar graph**.

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>$3,863.00</td>
<td>$1,117.00</td>
<td>$8,237.00</td>
<td>$8,690.00</td>
<td></td>
</tr>
<tr>
<td>$9,355.00</td>
<td>$1,100.00</td>
<td>$10,185.00</td>
<td>$18,749.00</td>
<td></td>
</tr>
<tr>
<td>$6,702.00</td>
<td>$2,116.00</td>
<td>$13,452.00</td>
<td>$8,046.00</td>
<td></td>
</tr>
<tr>
<td>$4,415.00</td>
<td>$1,089.00</td>
<td>$4,404.00</td>
<td>$20,114.00</td>
<td></td>
</tr>
</tbody>
</table>

• **Color Scales** change the color of each cell based on its value. Each color scale uses a **two- or three- color gradient**. For example, in the **Green - Yellow - Red** color scale, the **highest** values are green, the **average** values are yellow, and the **lowest** values are red.

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>$3,863.00</td>
<td>$1,117.00</td>
<td>$8,237.00</td>
<td>$8,690.00</td>
<td></td>
</tr>
<tr>
<td>$9,355.00</td>
<td>$1,100.00</td>
<td>$10,185.00</td>
<td>$18,749.00</td>
<td></td>
</tr>
<tr>
<td>$6,702.00</td>
<td>$2,116.00</td>
<td>$13,452.00</td>
<td>$8,046.00</td>
<td></td>
</tr>
<tr>
<td>$4,415.00</td>
<td>$1,089.00</td>
<td>$4,404.00</td>
<td>$20,114.00</td>
<td></td>
</tr>
</tbody>
</table>

• **Icon Sets** add a specific icon to each cell based on its value.

To *use pre-set conditional formatting*

1. Select the **desired cells** for the conditional formatting rule.
2. Click the **Conditional Formatting** command. A drop-down menu will appear.
3. Hover the mouse over the **desired preset**, then choose a **preset style** from the menu that appears.
4. The conditional formatting will be applied to the selected cells.

**Challenge!**

1. Open an **existing Excel workbook**.
2. Apply conditional formatting to a range of cells with **numerical values**.
3. Apply a second conditional formatting rule to the same set of cells.
4. Clear all conditional formatting rules from the worksheet.
2.4. Sparklines

Sometimes you may want to analyze and view trends in your data without creating an entire chart. Sparklines are miniature charts that fit into a single cell. Because they're so compact, it's easy to include several sparklines in a workbook.

2.4.1. Types of sparklines

There are three different types of sparklines: Line, Column, and Win/Loss. Line and Column work the same as line and column charts. Win/Loss is similar to Column, except it only shows whether each value is positive or negative instead of how high or low the values are. All three types can display markers at important points, such as the highest and lowest points, to make them easier to read.

Sparklines are ideal for situations when you need a clear overview of the data at a glance and when you don't need all of the features of a full chart. On the other hand, charts are ideal for situations when you want to represent the data in greater detail, and they are often better for comparing different data series.

To create sparklines

Generally, you will have one sparkline for each row, but you can create as many as you want in any location. Just like formulas, it's usually easiest to create a single sparkline and then use the fill handle to create sparklines for the adjacent rows. In our example, we'll create sparklines to help visualize trends in sales over time for each salesperson.

1. Select the cells that will serve as the source data for the first sparkline. In our example, we'll select the cell range B5:G5.
2. Select the **Insert** tab, then choose the desired **Sparkline** from the **Sparklines** group. In our example, we'll choose **Line**.

3. The **Create Sparklines** dialog box will appear. Use the mouse to select the cell where the sparkline will appear, then click **OK**. In our example, we'll select cell **H5**, and the cell reference will appear in the **Location Range:** field.

4. The sparkline will appear in the specified cell.
5. Click, hold, and drag the fill handle to create sparklines in adjacent cells.

6. Sparklines will be created for the selected cells. In our example, the sparklines show clear trends in sales over time for each salesperson in our worksheet.

<table>
<thead>
<tr>
<th>Last Name</th>
<th>May</th>
<th>June</th>
<th>July</th>
<th>August</th>
<th>September</th>
<th>October</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smith</td>
<td>$14,258.00</td>
<td>$557.00</td>
<td>$3,863.00</td>
<td>$1,117.00</td>
<td>$8,237.00</td>
<td>$8,690.00</td>
</tr>
<tr>
<td>Johnson</td>
<td>$25,822.00</td>
<td>$1,042.00</td>
<td>$9,355.00</td>
<td>$1,100.00</td>
<td>$10,185.00</td>
<td>$18,749.00</td>
</tr>
<tr>
<td>Doe</td>
<td>$19,854.00</td>
<td>$3,072.00</td>
<td>$6,702.00</td>
<td>$2,116.00</td>
<td>$13,452.00</td>
<td>$8,046.00</td>
</tr>
<tr>
<td>Black</td>
<td>$2,888.00</td>
<td>$3,755.00</td>
<td>$4,415.00</td>
<td>$1,089.00</td>
<td>$4,404.00</td>
<td>$20,114.00</td>
</tr>
<tr>
<td>Williams</td>
<td>$6,000.00</td>
<td>$3,152.00</td>
<td>$11,601.00</td>
<td>$1,122.00</td>
<td>$3,170.00</td>
<td>$10,733.00</td>
</tr>
<tr>
<td>Brown</td>
<td>$5,200.00</td>
<td>$4,056.00</td>
<td>$3,726.00</td>
<td>$1,135.00</td>
<td>$8,817.00</td>
<td>$18,524.00</td>
</tr>
</tbody>
</table>

2.4.2. Modifying sparklines

It's easy to change the way sparklines appear in your worksheet. Excel allows you to customize a sparkline's markers, style, type, and more.

To display markers

Certain points on a sparkline can be emphasized with markers, or dots, making the sparkline more readable. For example, in a line with a lot of ups and downs, it might be difficult to tell which values are the highest and lowest points. Showing the High Point and Low Point will make them easier to identify.

1. Select the sparkline(s) you want to change. If they are grouped in adjacent cells, you'll only need to click on one sparkline to select them all.

2. From the Design tab, select the desired option(s) from the Show group. In our example, we'll select High Point and Low Point.

3. The sparkline(s) will update to show the selected markers.
To change the sparkline style

1. Select the sparkline(s) you want to change.
2. From the Design tab, click the More drop-down arrow.
3. Choose the desired style from the drop-down menu.
4. The sparkline(s) will update to show the selected style.

To change the sparkline type

1. Select the sparkline(s) you want to change.
2. From the Design tab, select the desired Sparkline type. In our example, we'll select Column.
3. The sparkline(s) will update to reflect the new type.
TIP: Some sparkline types will be better suited for certain types of data. For example, Win/Loss is best suited for data where there could be positive and negative values (such as net earnings).

Changing the display range

By default, each sparkline is scaled to fit the maximum and minimum values of its own data source: The maximum value will go to the top of the cell, while the minimum will go to the bottom. However, this doesn’t show how high or low the values are when compared to the other sparklines. Excel allows you to modify the sparkline display range, which makes it easier to compare sparklines.

To change the display range:

1. Select the sparklines you want to change.
2. From the Design tab, click the Axis command. A drop-down menu will appear.
3. Below Vertical Axis Minimum Value Options and Vertical Axis Maximum Value Options, select Same for All Sparklines.
4. The sparklines will update to reflect the new display range.

Challenge!

1. Open an existing Excel workbook.
2. Create a sparkline on the first row of data.
3. Use the fill handle to create sparklines for the remaining rows.
4. Create markers for the High Point and Low Point.
5. Change the sparkline type.
6. Change the display range to make the sparklines easier to compare.
2.5. Collating Data from Several Worksheets

Excel allows you to refer to any cell on any worksheet, which can be especially helpful if you want to reference a specific value from one worksheet to another. To do this, you'll simply need to begin the cell reference with the worksheet name followed by an exclamation point (!). For example, if you wanted to reference cell A1 on Sheet1, its cell reference would be Sheet1!A1.

To reference cells across worksheets

In our example below, we'll refer to a cell with a calculated value between two worksheets. This will allow us to use the exact same value on two different worksheets without rewriting the formula or copying data between worksheets.

1. Locate the cell you wish to reference, and note its worksheet. In our example, we want to reference cell B11 on the Sales worksheet.

2. Navigate to the desired worksheet. In our example, we'll select the Catering Invoice worksheet.
3. The selected worksheet will appear.

4. Locate and select the cell where you want the value to appear. In our example, we'll select cell B4.

5. Type the equals sign (=), the sheet name followed by an exclamation point (!), and the cell address. In our example, we'll type ="Sales"!B11.

6. Press Enter on your keyboard. The value of the referenced cell will appear.
**TIP:** If you rename your worksheet at a later point, the cell reference will be updated automatically to reflect the new worksheet name.

---

**To replicate a worksheet**

In our example, we’ll create the following sheet in a workbook, saving the workbook as *Faculty.xls*

1. Rename the sheet from Sheet1 to **2010**

2. To create Sheet2, instead of retyping the information copy the sheet **click on the 2010 tab and keep the mouse pressed, hold down the Ctrl key, and release the mouse** to the right of the 2010 Tab.
3. **Enter** the figures for 2011, by overwriting the 2010 figures. The Yearly Totals will automatically update.

4. **Change** the Year in cell A1 to 2011 and **Rename** the sheet to 2011.

5. To create the sheet for 2012, we can copy the 2011 sheet. Again change the figures and the Year to 2012 in cell A1. Rename the sheet to 2012.

**Formulas – using cells from different worksheets**

To calculate the Total for Arts for 2010, 2011 & 2012 using the manual option.

1. In cell **B2** of the **Faculty Totals** worksheet type the heading **Totals**.

2. Click in cell **B3** of the **Faculty Totals** worksheet and type the equals sign =

3. Click on **2010** sheet, and select the cell with the Arts figures, **B3** type the + addition symbol.

4. Click on **2011** sheet, and select the cell with the Arts figures, **B3** type the + addition symbol. Click on **2012** sheet and select the cell with the Arts figures, **B3** and press **Enter**.

5. Once you press **Enter**, it should return you to the Faculty Totals sheet with a totals figure for Arts in cell B3. Notice the formula in the formula bar.

6. Use the AutoFill to copy this formula for the other faculties.

![Screen Shot](image.png)

**Functions – using cells from different worksheets**

To calculate the Average for Arts for 2010, 2011 & 2012 using the insert function option.
1. In cell C2 of the Faculty Totals type the heading Average.

2. Click into cell C3 of the Faculty Totals worksheet and insert the average function (use the Insert Function button either on the Formulas Tab or Formula Bar).

3. Click into Number1 and click on 2010 sheet, and select the cell B3.

4. Click into Number2 and click on 2011 sheet, and select the cell B3.

5. Click into Number3 and click on 2012 sheet, and select the cell B3.

6. Click on OK, once you press OK, it will return to the Faculty Totals sheet displaying an average figure for Arts in cell B3. Notice the formula in the formula bar.

7. Use the AutoFill to copy this function for the other faculties.

3. Advanced Functions

There are a variety of functions. Here are some of the most common functions you'll use:

- **SUM**: This function adds all the values of the cells in the argument.
AVERAGE: This function determines the average of the values included in the argument. It calculates the sum of the cells and then divides that value by the number of cells in the argument.

COUNT: This function counts the number of cells with numerical data in the argument. This function is useful for quickly counting items in a cell range.

MAX: This function determines the highest cell value included in the argument.

MIN: This function determines the lowest cell value included in the argument.

3.1. AutoSum

The SUM function is the most commonly used function so to make it more accessible there is an AutoSum button on the Home tab.

1. Position the cell pointer in the cell that will contain the result of the function.

2. Click on the AutoSum button Excel will guess the range of cells to be calculated and it will insert the =SUM function. If the range of cells is not correct use the mouse to select the correct range of cells to be added.

   TIP: use the mouse and the Ctrl key to select non-adjacent cells.

3. Press return to display the results in the cell or click on the tick on the formula bar.
Using the Average, Count, Max and Min Functions

1. Click on the down arrow to the right of the AutoSum button and select the required function e.g. Average.

2. Excel will guess the range of cells to be calculated and it will insert the =Average function. If the range of cells is not correct use the mouse to select the correct range of cells to be included in the calculation.

3. Press return to display the results in the cell or click on the tick on the formula bar.

3.2. IF Function

The IF function checks whether a condition is met, and returns one value if TRUE and another value if FALSE.

Use the IF function, one of the logical functions, to return one value if a condition is true and another value if it's false.

Syntax: IF(logical_test, value_if_true, [value_if_false])

- logical_test (required) = the condition you want to test.
- value_if_true (required) = the value that you want returned if the result of logical_test is TRUE.
- value_if_false (optional) = the value that you want returned if the result of logical_test is FALSE.

For example:

- =IF(A2>B2,"Over Budget","OK")
- =IF(A4=500,B4-A4,"")
- =IF(A2<B2,TRUE, IF(A3>B3,"over budget","OK"))
- =IF(AND(A1>15, B1<3),"Correct","Incorrect")

Use nested functions in a formula

Using a function as one of the arguments in a formula that uses a function is called nesting, and we’ll refer to that function as a nested function.

Nested IF functions work by replacing one or both of the TRUE/FALSE calculations with another IF function.

For example, imagine you have a sales team of five people, and you need to calculate their commission for the month based on their sales figures.
Your commission plan works as follows:

- If someone sells less than $400 in a month, they get 7% commission.
- For sales between $400 and $750, they get 10% commission.
- For sales between $750 and $1000, they get 12.5% commission.
- For sales over $1000, they get 16% commission.

Rather than calculate each of these commission figures individually, you decide to use a nested IF formula instead. The logical tests you would use in this case are these:

- Is commission less than $400? If TRUE, then calculate commission.
- If FALSE, then is commission less than $750? If TRUE then calculate commission.
- If FALSE, then is commission less than $1000? If TRUE then calculate commission.
- If FALSE, then calculate commission (because it must be more than $1000 - we don't need to do another logical test for this).

The formula to represent this to calculate commission for Bob looks like this:

```
=IF(B4<400,B4*7%,IF(B4<750,B4*10%,IF(B4<1000,B4*12.5%,B4*16%)))
```

Sometimes the VLOOKUP function can sometimes be a better solution in a scenario like this.

### 3.3. VLookup Function

Use VLOOKUP, one of the lookup and reference functions, when you need to find things in a table or a range by row. For example, look up an employee’s last name by her employee number, or find her phone number by looking up her last name (just like a telephone book).

The secret to VLOOKUP is to organize your data so that the value you look up (employee’s last name) is to the left of the return value you want to find (employee’s phone number).

Syntax: `VLOOKUP (lookup_value, table_array, col_index_num, [range_lookup])`
• lookup_value (required) = the value you want to lookup. The value you want to look up must be in the first column of the range of cells you specify in table-array. For example, if table-array spans cells B2:D7, then your lookup_value must be in column B. See the graphic below. Lookup_value can be a value or a reference to a cell.

• Table_array (required) = the range of cells that VLOOKUP will search for the Lookup_value and the return value. The first column in the cell range must contain the Lookup_value (for example, Last Name in the graphic below.) The cell range also needs to include the return value (for example, First Name in the graphic below) you want to find.

• col_index_num (required) = the column number (starting with 1 for the left-most column of table-array) that contains the return value.

• range_lookup (optional) = tells VLOOKUP if it should look for approximate or exact matches: FALSE searches for the exact value in the first column; TRUE assumes the first column in the table is sorted either numerically or alphabetically, and will then search for the closest value. This is the default method if you don't specify one.

In our example, it will search for the Product ID number on the Products worksheet. It first searches vertically down the first column (VLOOKUP is short for "vertical lookup"). When it finds the desired product ID, it moves to the right to find the product name and product price.

1. We'll start by typing an equals sign (=), followed by the function name and an open parenthesis: =VLOOKUP(

2. Next, we'll add each of the four arguments, separate them with commas, then close the parentheses: =VLOOKUP(A2, Products!$A$2:$C$13, 2, FALSE)
Note that we're using absolute references so this range won’t change when we copy the formula to other cells.

3.4. What-If Analysis

What-If Analysis in Excel allows you to try out different values (scenarios) for formulas. This feature can help you experiment and answer questions with your data, even when the data is incomplete.

Goal Seek

Whenever you create a formula or function in Excel, you put various parts together to calculate a result. Goal Seek works in the opposite way: it lets you start with the desired result, and it calculates the input value that will give you that result.

Let's imagine you're enrolled in a class. You currently have a grade of 65, and you need at least a 70 to pass the class. Luckily, you have one final assignment that might be able to raise your average. You can use Goal Seek to find out what grade you need on the final assignment to pass the class.

In the image below, you can see that the grades on the first four assignments are 58, 70, 72, and 60. Even though we don't know what the fifth grade will be, we can write a formula, or function, that calculates the final grade. In this case, each assignment is weighted equally, so all we have to do is average all five grades by typing =AVERAGE(B2:B6). Once we use Goal Seek, cell B6 will show us the minimum grade we'll need to make on that assignment.
1. Select the cell whose value you wish to change. Whenever you use Goal Seek, you'll need to select a cell that already contains a formula or function. In our example, we'll select cell B7 because it contains the formula =AVERAGE(B2:B6).

2. From the Data tab, click the What-if Analysis command, then select Goal Seek from the drop-down menu.

3. A dialog box will appear with three fields:
   - **Set cell:** This is the cell that will contain the desired result. In our example, cell B7 is already selected.
   - **To value:** This is the desired result. In our example, we'll enter 70 because we need to earn at least that to pass the class.
   - **By changing cell:** This is the cell where Goal Seek will place its answer. In our example, we'll select cell B6 because we want to determine the grade we need to earn on the final assignment.
4. When you’re done, click **OK**.

5. The dialog box will tell you if Goal Seek was able to find a solution. Click **OK**.

![Goal Seek Status](image)

6. The result will appear in the specified cell. In our example, Goal Seek calculated that we will need to score at least a 90 on the final assignment to earn a passing grade.

![Excel Sheet](image)

3.5. Name Ranges

A **name range** is a description that you assign to a cell or group of cells. Names are an alternative to cell references. Once a name has been defined, you can refer to it in a formula; for example, =sum(Year1). You can use names to move quickly to a certain area of the workbook or to specify print ranges.

Excel named ranges are formula boosters.

When assigning range names to a cell or cell range, you need to follow a few guidelines:

- **Range names must begin with a letter of the alphabet, not a number.**

  For example, instead of 01Profit, use Profit01.

- **Range names cannot contain spaces.**

  Instead of a space, use the underscore (Shift+hyphen) to tie the parts of the name together. For example, instead of Profit 01, use Profit_01.

- **Range names cannot correspond to cell coordinates in the worksheet.**
Excel Training - Level 2

For example, you can’t name a cell Q1 because this is a valid cell coordinate. Instead, use something like Q1_sales.

**To name a cell or cell range**

1. **Select the cell or cell range** that you want to name.
2. Click the **Formulas** tab.
3. Select **Define Name**.
4. Type the name for the selected cell or cell range in the Name Box.
5. Press **Enter**.

You can use the **Name Manager** box to work with all of the defined names in the workbook.
3.6. Array formulas

An array formula is a formula that can perform multiple calculations on one or more of the items in an array. Single cell array formulas perform multiple calculations in one cell.

**Without Array Formula**

Without using an array formula, we would execute the following steps to find the greatest progress.

1. First, we would calculate the progress of each student.

   ![Excel Table](image)

<table>
<thead>
<tr>
<th>Student</th>
<th>Test A</th>
<th>Test B</th>
<th>Progress</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anna</td>
<td>54</td>
<td>78</td>
<td>24</td>
</tr>
<tr>
<td>Kyle</td>
<td>36</td>
<td>69</td>
<td>33</td>
</tr>
<tr>
<td>Lisa</td>
<td>42</td>
<td>82</td>
<td>40</td>
</tr>
<tr>
<td>John</td>
<td>38</td>
<td>75</td>
<td>37</td>
</tr>
<tr>
<td>Craig</td>
<td>69</td>
<td>86</td>
<td>17</td>
</tr>
</tbody>
</table>

2. Next, we would use the MAX function to find the greatest progress.

   ![Excel Table](image)

<table>
<thead>
<tr>
<th>Student</th>
<th>Test A</th>
<th>Test B</th>
<th>Progress</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anna</td>
<td>54</td>
<td>78</td>
<td>24</td>
</tr>
<tr>
<td>Kyle</td>
<td>36</td>
<td>69</td>
<td>33</td>
</tr>
<tr>
<td>Lisa</td>
<td>42</td>
<td>82</td>
<td>40</td>
</tr>
<tr>
<td>John</td>
<td>38</td>
<td>75</td>
<td>37</td>
</tr>
<tr>
<td>Craig</td>
<td>69</td>
<td>86</td>
<td>17</td>
</tr>
</tbody>
</table>

   ![Excel Table](image)

<table>
<thead>
<tr>
<th>Student</th>
<th>Test A</th>
<th>Test B</th>
<th>Progress</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anna</td>
<td>54</td>
<td>78</td>
<td>24</td>
</tr>
<tr>
<td>Kyle</td>
<td>36</td>
<td>69</td>
<td>33</td>
</tr>
<tr>
<td>Lisa</td>
<td>42</td>
<td>82</td>
<td>40</td>
</tr>
<tr>
<td>John</td>
<td>38</td>
<td>75</td>
<td>37</td>
</tr>
<tr>
<td>Craig</td>
<td>69</td>
<td>86</td>
<td>40</td>
</tr>
</tbody>
</table>

**With Array Formula**

We don't need to store the range in column D. Excel can store this range in its memory. A range stored in Excel's memory is called an **array constant**.

1. We already know that we can find the progress of the first student by using the formula below.
2. To find the greatest progress, add the \textbf{MAX} function, replace C2 with C2:C6 and B2 with B2:B6.

3. Finish by pressing \textbf{CTRL + SHIFT + ENTER}.

Note: The formula bar indicates that this is an array formula by enclosing it in curly braces \{\}. Do not type these yourself. They will disappear when you edit the formula.
Explanation: The range (array constant) is stored in Excel's memory, not in a range. The array constant looks as follows: {24;33;40;37;17}

This array constant is used as an argument for the MAX function, giving a result of 40.

_F9 Key_

When working with array formulas, you can have a look at these array constants yourself.


2. Press **F9**.

_TIP:_ Elements in a vertical array constant are separated by semicolons. Elements in a horizontal array constant are separated by commas.
4. Using Tables

Once you've entered information into a worksheet, you may want to format your data as a **table**. Just like regular formatting, tables can improve the **look and feel** of your workbook, but they'll also help to **organize** your content and make your data easier to use. Excel includes several **tools** and **predefined table styles**, allowing you to create tables quickly and easily.

**To format data as a table**

1. **Select the cells** you want to format as a table. In our example, we'll select the cell range A4:G12.

2. **From the Home tab**, click the **Format as Table** command in the **Styles** group.

3. **Select a table style** from the drop-down menu.
4. A dialog box will appear, confirming the selected cell range for the table.

5. If your table has headers, check the box next to My table has headers, then click OK.

6. The cell range will be formatted in the selected table style.

* TIP: Tables include filtering by default. You can filter your data at any time using the drop-down arrows in the header cells.
Modifying tables

It's easy to modify the look and feel of any table after adding it to a worksheet. Excel includes different options for customizing a table, including adding rows or columns, changing the table style, and more.

To add rows or columns to a table:

If you need to fit more content in your table, Excel allows you to modify the table size by including additional rows and columns. There are two simple ways to change the table size:

☑ Begin typing new content after the last row or column in the table. The row or column will be included in the table automatically.

☑ Click, hold, and drag the bottom-right corner of the table to create additional rows or columns.

To change the table style

1. Select any cell in your table, then click the Design tab.

2. Locate the Table Styles group, then click the More drop-down arrow to see all available table styles.

3. Select the desired style.

4. The selected table style will appear.

To modify the table style options
You can turn various options on or off to change the appearance of any table. There are six options: Header Row, Total Row, Banded Rows, First Column, Last Column, and Banded Columns.

1. Select any cell in your table.
2. From the Design tab, check or uncheck the desired options in the Table Style Options group. In our example, we'll check Total Row to automatically include a total for our table.

To remove a table

Sometimes you may not want to use the additional features included with tables, such as the Sort and Filter drop-down arrows. You can remove a table from the workbook while still preserving the table's formatting elements, like font and cell color.

1. Select any cell in your table. The Design tab will appear.
2. Click the Convert to Range command in the Tools group.
3. A dialog box will appear. Click Yes.
4. The range will no longer be a table, but the cells will retain their data and formatting.

Challenge!

1. Open an existing Excel workbook.
2. Format a range of cells as a table.
3. Add a row or column to the table.
4. Choose a new table style.
5. Change the table style options.
6. Remove the table.
5. Chart Tools

Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart types that you can choose from when you create a chart. Excel offers Pie, Line, Bar, and Column charts to name but a few. Showing data in a chart can make it clearer, more interesting and easier to read. Charts can also help you evaluate your data and make comparisons between different values. Try the Recommended Charts command, new to Excel 2013, on the Insert tab to quickly create a chart that’s just right for your data.

To create a Chart

1. Select the data that you want to use in the chart – remember for non-adjacent cells use the Ctrl key with the mouse.

2. Click on the Insert Tab

3. In the Chart Group select the Chart Type that you require. From the drop down list select the version of the chart you require or Click on the Recommend Charts button and select a chart layout that Excel recommends for your data.

4. The chart will display on your worksheet and the Chart Tools Tabs will display.
Chart Shortcuts

☑ Chart Elements – Add, remove or change chart elements such as the title, legend, gridlines, and data labels.

☑ Chart Styles – These can be used to change the look and colours used in a chart.

☑ Chart Filters – Edit what data points and names are visible on your chart.
To access additional design and formatting features, click anywhere in the chart to add the Chart Tools to the ribbon, and then click the options you want on the Design and Format tabs.

5.1. Formatting a chart

Although the Chart Tools ribbon is full of cool things you can do to your chart, sometimes you might want more control. In earlier versions of Office, advanced formatting options were buried deeply in hard to find, complex dialog boxes. Now these options are available in clean, shiny, new task panes.

1. Select the chart element (for example, data series, axes, or titles), right-click it.

2. Click Format <chart element>. The new Format pane appears with options that are tailored for the selected chart element.
For example, to format an axis:

1. Right-click the chart axis, and click **Format Axis**.

   ![Format Axis](image)

2. In the **Format Axis** task pane, make the tweaks you want.

5.2. Creating a Combo Chart

A **combination chart** is a chart that combines two or more chart types in a single chart.

To create a combination chart, execute the following steps.

1. **Select the data** that you want to use in the chart.

2. On the **Insert** tab, in the Charts group, choose **Combo**.
3. The Combo chart will display on your worksheet.

**TIP:** When you are comparing data series that have a wide “gap” between them – e.g. comparing actual sales in a month (large number) – to Profit % in each month (small number), you will want to create a Secondary Vertical (Value) Axis in your Combination Chart. Begin by selecting the series that you want to plot and Right Mouse Click to Format the Series on a Secondary Vertical Axis. I recommend that you add in Axis Titles for both the Primary and Secondary Vertical Axes.
6. Applying Formatting

All cell content uses the same formatting by default, which can make it difficult to read a workbook with a lot of information. Basic formatting can customize the look and feel of your workbook, allowing you to draw attention to specific sections and making your content easier to view and understand.

6.1. Working with Styles

Rather than formatting cells manually, you can use Excel's predefined cell styles. Cell styles are a quick way to include professional formatting for different parts of your workbook, such as titles and headers.

To apply a cell style

1. Select the cell(s) you wish to modify.
2. Click the Cell Styles command on the Home tab, then choose the desired style from the drop-down menu. In our example, we'll choose Accent 1.
3. The selected cell style will appear.
Formatting text and numbers

One of the most powerful tools in Excel is the ability to apply specific formatting for text and numbers. Instead of displaying all cell content in exactly the same way, you can use formatting to change the appearance of dates, times, decimals, percentages (%), currency ($), and much more.

To apply number formatting:

1. Select the cells(s) you wish to modify.
2. Click the drop-down arrow next to the Number Format command on the Home tab. The Number Formatting drop-down menu will appear.
3. Select the desired formatting option. In our example, we will change the formatting to Long Date.
4. The selected cells will change to the new formatting style.
6.2. Insert headers and footers

You can make your workbook easier to read and look more professional by including **headers and footers**. The **header** is a section of the workbook that appears in the **top margin**, while the **footer** appears in the **bottom margin**. Headers and footers generally contain information such as page number, date, and workbook name.

1. Locate and select the **Page Layout view** command at the bottom of the Excel window. The worksheet will appear in Page Layout view.

2. Select the desired **header** or **footer** you wish to modify. In our example, we'll modify the **footer** at the bottom of the page.

3. The **Header & Footer Tools** tab will appear on the **Ribbon**. From here, you can access commands that will automatically include page numbers, dates, and workbook names. In our example, we'll add **page numbers**.

4. The footer will change to include page numbers automatically.
6.3. Paste Special

Paste Special is useful to copy only values, formulas, comments, or cell formats. Instead of copying entire cells, you can copy specified contents from the cells — for example, you can copy the resulting value of a formula without copying the formula itself.

1. Select the cells you want to copy.
2. Right click and select Copy.
3. Select the paste area.
4. Right click and select Paste Special. The following dialogue box appears:

- All - pastes all cell contents and formatting. This option is the same as using the Paste command on the Edit menu.
- Formula - pastes only the formulas as entered in the formula bar.
- Values - pastes only the values as displayed in the cells.
- Formats - pastes only cell formatting.

5. Select an option under the Paste heading, and then click OK.

- Transpose - changes columns of copied data to rows, and vice versa.
- Paste Link - links the pasted data to the active worksheet.