Subject: categories: RFN (Request for Notation)

From: "David B. Benson" <[email-masked]>
Date: Sun, 26 Nov 2000 13:25:22 -0800

Dear Colleagues,

I am preparing notes for a sophomore (second year)
course, and I am finding several places wherein
I can find no standard notation.  Your suggestions
will be most appreciated.

(1) Everybody knows that {(n,n+1) | n \in Z}
    is the <<successor>> relation.  What to call
    the corresponding idea when the underlying
    order is only a partial order?
      I am currently using <<followers>> as in
    phrases such as
    ``...the followers relation for the subsets
    of the finite set {a, b, c}...''
    in which ({a},{a,b}) is in the followers
    relation, but {{a},{a,b,c}) is not, anymore
    that (n,n+2) is in the successor relation.

      Is there a better word than <<followers>>?

(2) I need a snappy name for an order pair in
    a relation R.  The books I have seem to just
    say ``...the ordered pair (x,y) in relation R...''
    The problem is that there are many uses of
    ordered pairs, and this is a specific use,
    a description of the fact that 
       x is R-related to y
    by the fact that (x,y) \in R.
      The word ``association'' will not do as this
    has other meaning in computer science.  I am
    considered <<relator>> for an order pair in
    a relation, but have the impression that this
    word has been used for other purposes in the
    literature.

(3) I badly need a good name for the sets
        Nat_k = {n \in Nat | n < k }
    These are widely used and I am surprised that
    there is no satisfactory name in wide-spread use.
      These are NOT the sets Z_k = Z mod k,
    although the Nat_k form a system of distinct,
    canonical representatives for the Z_k.
      These are the set of array indices in computer
    languages such as C and SML.  In this use, the
    Nat_k have nothing whatsoever to do with Z_k
    and I certainly do not want to confuse the students!

Thank you in advance for any and all suggestions,
David
--
Professor David B. Benson                                (509) 335-2706
School of EE and Computer Science (EME 102A)             (509) 335-3818 fax
PO Box 642752, Washington State University               [email-masked]
Pullman WA 99164-2752   U.S.A.

---

From: Justin Pearson <[email-masked]>
Date: Mon, 27 Nov 2000 17:39:48 +0100

>     say ``...the ordered pair (x,y) in relation R...''

Depends what you want to talk about. If you want to talk about R as
simple a set then I would normally  refer to an
element of R a tuple of R where the context tells you that
the tuple is of length two. 

Regards

Justin