Subject: categories: Re: stupid question?

From: Peter Freyd <[email-masked]>
Date: Wed, 29 Mar 2000 15:23:16 -0500 (EST)

M.M. Mawanda asks:

>I have been asked the following question: Is it true that any function
>defined in a real number closed interval [a,b] (there is not a hypothesis
>of continuity) is bounded in an open  subinterval (c,d) of [a,b]? My
>spontaneous was NO. Unfortunately I cannot find a counter-example to
>disapproved my answer. Can someone help.     

No it is not true. For example, the function defined by:

  f(x) =  if  x  is irrational then  0  else
          if  x =  p/q  where  p  and  q  are co-prime then  q.

---

From: Michael Barr <[email-masked]>
Date: Wed, 29 Mar 2000 20:32:21 -0500 (EST)

It is not even true for additive functions.  Take a Hamel base and send
every element of the base to 1.