Subject: categories: Re: Re: stupid question?

From: [email-masked] (Max Kanovitch)
Date: Wed, 29 Mar 2000 18:13:53 -0500 (EST)

Dear M.M. Mawanda,
 
 > >I have been asked the following question: Is it true that any function
 > >defined in a real number closed interval [a,b] (there is not a hypothesis
 > >of continuity) is bounded in an open  subinterval (c,d) of [a,b]?

 The real fun is about a function f such that
 f is unbounded in any open interval (c,d), and
 in addition to that:     f(x+y) = f(x)+f(y).
 
 > Date: Wed, 29 Mar 2000 15:23:16 -0500 (EST)
 > From: Peter Freyd <[email-masked]>
 > Subject: categories: Re: stupid question?
 > 
 >  M.M. Mawanda asks:
 > 
 > >I have been asked the following question: Is it true that any function
 > >defined in a real number closed interval [a,b] (there is not a hypothesis
 > >of continuity) is bounded in an open  subinterval (c,d) of [a,b]? My
 > >spontaneous was NO. Unfortunately I cannot find a counter-example to
 > >disapproved my answer. Can someone help.     
 > 
 > No it is not true. For example, the function defined by:
 > 
 >   f(x) =  if  x  is irrational then  0  else
 >           if  x =  p/q  where  p  and  q  are co-prime then  q.
 >

---

From: Todd Wilson <[email-masked]>
Date: Wed, 29 Mar 2000 19:00:25 -0800 (PST)

>  in addition to that:     f(x+y) = f(x)+f(y).

Using AC/Zorn's Lemma, we can construct 2^(2^Aleph_0) such functions,
as follows.  Let B be a basis for the reals R as a rational vector
space.  Clearly, |B| = 2^Aleph_0.  For any non-empty proper subset C
of B, let g be its characteristic function (g(x)=1 if x in C, g(x)=0
otherwise) and let f be the unique linear extension of g to R.  Then f
is linear, and its graph is dense in R^2, since, if c and d are such
that g(c)=1 and g(d)=0, then f(qc+rd) = q for all rationals q,r, and r
can be varied to make qc+rd as close as desired to any given real.

-- 
Todd Wilson
Computer Science Department
California State University, Fresno